Small number of customers in us-west-2 may experience elevated API latencies

Incident Report for Temporal

Resolved

Retroactive update: Latencies in us-west-2 returned to normal levels after the fix was applied, and the incident was considered resolved at 23:30 UTC on Jan 26. No additional customer impact was observed.
Posted Jan 27, 2026 - 14:28 UTC

Update

Monitoring
Posted Jan 26, 2026 - 23:31 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 26, 2026 - 23:29 UTC

Update

Investigation ongoing.
Posted Jan 26, 2026 - 22:37 UTC

Update

We are still investigating the root cause. Performance is recovering. Some customers may still see elevated API latencies.
Posted Jan 26, 2026 - 21:53 UTC

Update

We are continuing to investigate this issue.
Posted Jan 26, 2026 - 21:44 UTC

Investigating

Small number of customers in us-west-2 may experience elevated API latencies.
Posted Jan 26, 2026 - 21:17 UTC
This incident affected: Amazon Web Services (AWS) (us-west-2).