Customers using external observability may experience elevated rate of API errors

Incident Report for Temporal

Resolved

This incident is resolved
Posted Mar 09, 2026 - 17:23 UTC

Monitoring

Errors have subsided for last 20 minutes and we will continue to monitor
Posted Mar 09, 2026 - 12:29 UTC

Identified

Customers using external observability may experience elevated rate of API errors
Posted Mar 09, 2026 - 12:11 UTC
This incident affected: Global Services (Metrics).