GCP customers in europe-west3 are experiencing elevated errors for Visibility API calls

Incident Report for Temporal

Resolved

The region has recovered — visibility calls are succeeding without errors. The incident is resolved.
Posted Jun 17, 2026 - 22:04 UTC

Update

A fix has been implemented. The visibility is coming back and we are monitoring.
Posted Jun 17, 2026 - 21:34 UTC

Investigating

We are currently investigating this issue.
Posted Jun 17, 2026 - 21:18 UTC