Customers might observe Usage API returning missing or delayed data

Incident Report for Temporal

Resolved

We have identified the root cause and confirmed that no customer impact occurred.
Posted Jun 11, 2026 - 15:32 UTC

Investigating

We are investigating an issue that may result in delayed or incomplete data being returned by the Usage API for customers.
Posted Jun 11, 2026 - 14:34 UTC
This incident affected: Global Services (Billing).