High latencies for some customers in GCP us-east4 region

Incident Report for Temporal

Resolved

This incident is resolved; the region has recovered.

This occurred due to a significant accumulation of timer tasks in the system, which required processing to clear. The backlog has since been resolved, and normal operations have resumed.
Posted Dec 18, 2025 - 22:53 UTC

Investigating

We are currently investigating the issue
Posted Dec 18, 2025 - 20:53 UTC
This incident affected: Google Cloud Platform (GCP) (us-east4).