Some customers in us-west-2 may experience elevated rate of API errors & higher latencies

Incident Report for Temporal

Resolved

Remediation has been completed at this time and we have confirmed the recovery of all affected namespaces.
Posted May 29, 2026 - 15:49 UTC

Monitoring

Latencies and error rates are stable after remediation and we are continuing to monitoring it.
Posted May 29, 2026 - 15:00 UTC

Update

Error rates remain stable, and we continue to implement remediation measures while monitoring service performance closely.
Posted May 29, 2026 - 14:50 UTC

Update

We continue to investigate the root cause while implementing remediation measures. Error rates have recovered.
Posted May 29, 2026 - 14:03 UTC

Update

Failover was initiated for the affected HA namespaces while we keep investigating the root cause.
Posted May 29, 2026 - 13:43 UTC

Identified

Some customers in us-west-2 may experience elevated rate of API errors & higher latencies
Posted May 29, 2026 - 13:31 UTC
This incident affected: Amazon Web Services (AWS) (us-west-2).