Some customers in AWS sa-east-1 may experience elevated API latencies

Incident Report for Temporal

Resolved

This incident has been resolved.
Posted Jun 06, 2026 - 04:26 UTC

Monitoring

The issue appears to have been transient network latency that has resolved. We are monitoring the situation.
Posted Jun 06, 2026 - 02:29 UTC

Investigating

Some customers in AWS sa-east-1 may experience elevated API latencies. We are currently investigating the issue.
Posted Jun 06, 2026 - 02:15 UTC
This incident affected: Amazon Web Services (AWS) (sa-east-1).