Customers in (GCP) us-west1 may experience elevated API latencies

Incident Report for Temporal

Resolved

We have continued to see normal activity in this region, with latencies holding at pre-incident levels.
This incident is now resolved.
Posted Aug 20, 2026 - 19:00 UTC

Monitoring

A fix has been implemented and we are seeing recovery. We will be continuing to monitor the results.
Posted Aug 20, 2026 - 18:10 UTC

Identified

Downstream cloud provider (GCP) is reporting issues. We are working with them to resolve this issue.
Posted Aug 20, 2026 - 16:05 UTC

Investigating

Customers in (GCP) us-west1 may experience elevated API latencies.
Posted Aug 20, 2026 - 15:20 UTC
This incident affected: Google Cloud Provider (GCP) (us-west1).