External metrics outage

Incident Report for Temporal

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 21:34 UTC

Monitoring

We are seeing a return to normal operations. We will continue to monitor the incident.
Posted Jun 12, 2025 - 21:07 UTC

Identified

The outage is due to an ongoing Google Cloud incident: https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW.
Posted Jun 12, 2025 - 19:39 UTC

Update

Our investigation is leading to the impact being related to the ongoing GCP outage.
Posted Jun 12, 2025 - 19:07 UTC

Update

We are continuing to investigate this issue.
Posted Jun 12, 2025 - 18:30 UTC

Investigating

Users ingesting metrics via Temporal Cloud's metrics endpoint will see no data
Posted Jun 12, 2025 - 18:29 UTC
This incident affected: Global Services (Metrics).