Degraded Child Workflow Execution

Incident Report for Temporal

Resolved

We identified and resolved an issue that caused some Child Workflows to fail to start under certain conditions. Affected Workflows have been reprocessed and are now operating normally as of 23:26 UTC.
Posted Apr 21, 2026 - 23:37 UTC

Investigating

We are investigating an issue where child workflows started with the TerminateIfRunning conflict policy may fail to start. The issue began approximately 2026-04-21 19:39 UTC.A fix is in progress and we will provide updates shortly.
Posted Apr 21, 2026 - 23:15 UTC
This incident affected: Google Cloud Platform (GCP) (europe-west3).