Some customers may be experiencing stuck workflows or activities

Incident Report for Temporal

Update

Refresh across open and closed workflows continues to progress smoothly. We're monitoring the situation and will post updates once complete.
Posted Jun 05, 2026 - 22:02 UTC

Update

As refresh of closed workflows progresses, some users may see unblocked stuck parent workflows from closed child workflows; this is happening because the missed task for closed child workflows is refreshed and delivered to parent. It could also happen on other stuck workflows that are waiting for task updates which were missed due to this incident.
Posted Jun 04, 2026 - 22:35 UTC

Update

We are continuing to monitor the ongoing refresh process for all open workflows. We are also considering options for refreshing closed workflows. We will continue to share more updates as this progresses.
Posted Jun 04, 2026 - 17:40 UTC

Monitoring

Workflows will continue to be refreshed overnight, and we are monitoring the situation.
Posted Jun 04, 2026 - 07:08 UTC

Update

Workflows will continue to be refreshed overnight, and we are monitoring the situation.
Posted Jun 04, 2026 - 06:45 UTC

Update

Refreshes are still in progress and we are monitoring the situation.
Posted Jun 04, 2026 - 06:14 UTC

Update

Rollback is complete; refresh of open workflows is underway to unblock impacted workflows.
Posted Jun 04, 2026 - 04:27 UTC

Update

The rollback is making progress across impacted cells, and we are continuing to monitor the situation.
Posted Jun 04, 2026 - 01:40 UTC

Update

Rollback is still in progress and we are continuing to monitor the situation.
Posted Jun 03, 2026 - 23:36 UTC

Identified

A bug in the recent update in History pagination caused a rare edge case where an extra task could be added before the response was returned. This incorrectly advanced the read level, causing some tasks to be skipped. We’ve identified the issue, and are currently rolling back the update to stop this from happening again.

We will be refreshing all executions in cells where the update was deployed and will monitor these closely. This will progress any stuck workflows, but will not impact any of the closed ones.
Posted Jun 03, 2026 - 21:35 UTC

Update

We're rolling back the recent update as a possible mitigation to avoid any further occurrences of this issue. We are however still in the process of investigating root cause and will post updates as we have them.
Posted Jun 03, 2026 - 20:41 UTC

Update

We are investigating a recent update that could have caused intermittent missed task dispatches, resulting in some tasks being stuck. Impact identified as of now is limited to a handful of workflows that were caught in a rare edge case. We will continue to share more updates as investigation progresses.
Posted Jun 03, 2026 - 19:51 UTC

Update

We are continuing to investigate this issue. Please report any stuck workflows or activities to support so we can help unblock them as we work on root cause investigation and resolution.
Posted Jun 03, 2026 - 18:30 UTC

Investigating

We are investigating a few reports where a workflow or activity is becoming stuck and not making progress when it should. Please report any such issues you see to support.
Posted Jun 03, 2026 - 00:45 UTC