Errors on GetSystemInfo and healthcheck endpoints for latest SDK versions

Incident Report for Temporal

Resolved

The rollout is complete and resolves the compression issues. All listed affected versions should no longer experience any compression-related errors.
Posted Jul 02, 2026 - 16:26 UTC

Monitoring

The fix has been rolled out across all regions, and we are actively monitoring.
Posted Jul 02, 2026 - 13:55 UTC

Update

Fix is being rolled out across all regions, current impact is limited to us-west-2 and us-east-1 regions. All systems stable and we're actively monitoring this. Next update will be posted once rollouts completed.
Posted Jul 01, 2026 - 22:12 UTC

Identified

Customers on the latest SDK versions may see decompression errors when calling the GetSystemInfo and gRPC health check endpoints, and in rare cases, some workflows may hit a non-determinism error (NDE) during replay. A fix for this is rolling out.

Affected versions -

Java 1.36.0
Go 1.45.0
TypeScript 1.19.0
Rust 0.5.0
Python 1.29.0

Workaround - Disable gzip compression in the SDK client (set gRPC compression to none)
Posted Jul 01, 2026 - 18:02 UTC