Small number of customers in AWS us-west-2 may experience delayed execution of schedules

Incident Report for Temporal

Resolved

This incident has been resolved.
Posted Apr 01, 2026 - 07:27 UTC

Monitoring

Impacted Schedules have been refreshed and backlogs have been cleared. Resources have been scaled out to mitigate.
Posted Apr 01, 2026 - 07:11 UTC

Update

We have identified a backlog of workflow tasks and are currently refreshing Workflows to unblock the stuck schedules.
Posted Apr 01, 2026 - 06:38 UTC

Identified

Small number of customers in AWS us-west-2 may experience delayed execution of schedules
Posted Mar 31, 2026 - 20:00 UTC
This incident affected: Amazon Web Services (AWS) (us-west-2).